Please consider supporting our efforts.The Dandy Forum is FREE but we do have running cost, please consider a small donation to help us cover our running cost.

Amount:
×
Sadly I have gone to the Dark Side (24 May 2017)

After years of running this site, I have now gone to The Dark Side. This web site will continue, but I really need someone new to take over.

× Questions and Answers

Fire away with any questions that you may have re the Dandy Trailer tent , folding camper

Topic-icon Electrics

  • Billbo
  • Billbo's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 years 5 months ago #626 by Billbo
Billbo created the topic: Electrics
Hi all been a while didn't know about new site anyway joined again as new member. We last used our Destiny Highside in about July last year to the Isle of Wight great tie no issues. We are currently at Pembrey opened the electric connector on the Destiny and had a flood of water come out dried it out and connected to the mains nothing worked dried it more still nothing on any of lights plugs etc. I opened the door and found the electric box had power showing and nothing was tripped. Can't see how to check fuses but surely tag would have blown switch. Any ideas please

Please Log in or Create an account to join the conversation.

  • NeilT
  • NeilT's Avatar
  • Offline
  • Moderator
  • Moderator
  • Love our Dandy
More
2 years 5 months ago #628 by NeilT
NeilT replied the topic: Electrics
Its a bit tricky trying to help not knowing your electrical system.
Are the 12v lights/sockets working?
Our 240 volt is plug sockets, but it connects a battery charger to charge up a 75amp leisure battery in the front box, and it is this that powers up the lights.
Is your leisure battery fully charged?

<<Its the way the mop flops>>

Please Log in or Create an account to join the conversation.

  • Billbo
  • Billbo's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 years 5 months ago #629 by Billbo
Billbo replied the topic: Electrics
Hi Neil we don't use a leisure battery, never connected one although I have the connectors to attach one and a charger at home from past caravaning. The lights have always worked on previous trips through the mains system. I could understand no power or tripped switches blown fuses but the box shows power and nothing tripped ? Very strange.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #630 by VosperD
VosperD replied the topic: Electrics
If the water is on an external connector and the trips are inside in the dry I would have thought would have tripped the site trip as soon as you connected..
Perhaps the water has corroded some terminals.
Don

Please Log in or Create an account to join the conversation.

  • Billbo
  • Billbo's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 years 4 months ago #725 by Billbo
Billbo replied the topic: Electrics
Just a quick update 2 weeks ago we went to Pembrey for a week and everything worked perfectly for the entire time, it must have just been a case of drying out thankfully.

I have drilled a small hole in the Dandy electrics socket to avoid a build up of water suggested by Ian who as always has been very helpful which should help. Also checked wiring with a socket tester supplied by Ian and no faults found.

Thanks for replies

Please Log in or Create an account to join the conversation.

Time to create page: 0.470 seconds
Powered by Kunena Forum
UA-31887120-1